nixos/spec/reimaden/default.nix
2025-01-13 11:52:09 +08:00

49 lines
1.1 KiB
Nix

{
global = {
id = "6b564d01975a4e93b4a51f34ba24e5b4";
fs.esp.uuid = "FC6D-75D8";
fs.type = "zfs";
boot.lanzaboote = true;
gpu.enable = true;
gpu.type = "intel";
gpu.arc = "8086:5691";
android.enable = true;
};
home = {
gnome.enable = true;
#headless.enable = "eDP-1";
gyroflow.enable = true;
jetbrains.enable = true;
vscode.enable = true;
libreoffice.enable = true;
steam.enable = true;
};
home.plasma.extraConfig = {
configFile = {
kcminputrc."Libinput/2362/597/UNIW0001:00 093A:0255 Touchpad".NaturalScroll = true;
};
};
powerManagement.enable = true;
powerManagement.cpuFreqGovernor = "powersave";
boot.kernelParams = [ "zfs.zfs_arc_max=34359738368" ];
boot.loader.timeout = 2;
hardware.enableRedistributableFirmware = true;
boot.initrd.availableKernelModules = [
"xhci_pci"
"thunderbolt"
"nvme"
"usb_storage"
"sd_mod"
];
boot.initrd.kernelModules = [ ];
boot.kernelModules = [ "kvm-intel" ];
boot.extraModulePackages = [ ];
hardware.cpu.intel.updateMicrocode = true;
imports = [ ./ac71 ];
}